hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11273) Move TransferFsImage#doGetUrl function to a Util class
Date Wed, 04 Jan 2017 01:34:58 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11273?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15796829#comment-15796829
] 

Jing Zhao commented on HDFS-11273:
----------------------------------

Thanks for the patch, [~hkoneru]! The patch looks good to me. Just two nits:
# We can use this chance to cleanup the imports of TransferFsImage and Util.
# In Util.java, CONTENT_LENGTH, MD5_HEADER, and deleteTmpFiles do not need to be public.

Besides we can add a little more details in the description to explain why moving the code
is necessary.

> Move TransferFsImage#doGetUrl function to a Util class
> ------------------------------------------------------
>
>                 Key: HDFS-11273
>                 URL: https://issues.apache.org/jira/browse/HDFS-11273
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Hanisha Koneru
>            Assignee: Hanisha Koneru
>         Attachments: HDFS-11273.000.patch
>
>
> TransferFsImage#doGetUrl function is required for JournalNode syncing as well. We can
move the code to a Utility class to avoid duplication of code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message