hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Junping Du (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-8982) Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
Date Fri, 06 Jan 2017 22:08:59 GMT

     [ https://issues.apache.org/jira/browse/HDFS-8982?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Junping Du updated HDFS-8982:
-----------------------------
    Target Version/s:   (was: 2.8.0)

> Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
> ----------------------------------------------------------------------------
>
>                 Key: HDFS-8982
>                 URL: https://issues.apache.org/jira/browse/HDFS-8982
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 2.7.1
>            Reporter: Zhe Zhang
>
> Currently {{INodeFile}} provides both {{getFileReplication}} and {{getPreferredBlockReplication}}
interfaces. At the very least they should be renamed (e.g. {{getCurrentFileReplication}} and
{{getMaxConfiguredFileReplication}}), with clearer Javadoc.
> I also suspect we are not using them correctly in all places right now.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message