hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brahma Reddy Battula (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11270) Document the missing options of NameNode bootstrap command
Date Fri, 23 Dec 2016 11:17:58 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11270?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15772585#comment-15772585
] 

Brahma Reddy Battula commented on HDFS-11270:
---------------------------------------------

[~linyiqun] thanks for working on this...

1)  I am thinking ,we should update at following like {{namenode format}} which will make
more sense..?.

org.apache.hadoop.hdfs.server.namenode.NameNode#USAGE.
{code}
  private static final String USAGE = "Usage: hdfs namenode ["
      + StartupOption.BACKUP.getName() + "] | \n\t["
      + StartupOption.CHECKPOINT.getName() + "] | \n\t["
      + StartupOption.FORMAT.getName() + " ["
      + StartupOption.CLUSTERID.getName() + " cid ] ["
      + StartupOption.FORCE.getName() + "] ["
      + StartupOption.NONINTERACTIVE.getName() + "] ] | \n\t["
      + StartupOption.UPGRADE.getName() + 
        " [" + StartupOption.CLUSTERID.getName() + " cid]" +
        " [" + StartupOption.RENAMERESERVED.getName() + "<k-v pairs>] ] | \n\t["
      + StartupOption.UPGRADEONLY.getName() + 
        " [" + StartupOption.CLUSTERID.getName() + " cid]" +
        " [" + StartupOption.RENAMERESERVED.getName() + "<k-v pairs>] ] | \n\t["
      + StartupOption.ROLLBACK.getName() + "] | \n\t["
      + StartupOption.ROLLINGUPGRADE.getName() + " "
      + RollingUpgradeStartupOption.getAllOptionString() + " ] | \n\t["
      + StartupOption.IMPORT.getName() + "] | \n\t["
      + StartupOption.INITIALIZESHAREDEDITS.getName() + "] | \n\t["
      + StartupOption.BOOTSTRAPSTANDBY.getName() + "] | \n\t["
      + StartupOption.RECOVER.getName() + " [ "
      + StartupOption.FORCE.getName() + "] ] | \n\t["
      + StartupOption.METADATAVERSION.getName() + " ]";
{code}

2) can we describe the options for {{zkfc}} also in the doc.It's not related to this jira,
but {{options}} are same..?

{noformat}Usage: hdfs zkfc [-formatZK [-force] [-nonInteractive]]{noformat}

If everyone agrees, you can change jira summary also.


> Document the missing options of NameNode bootstrap command
> ----------------------------------------------------------
>
>                 Key: HDFS-11270
>                 URL: https://issues.apache.org/jira/browse/HDFS-11270
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: documentation
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Yiqun Lin
>            Assignee: Yiqun Lin
>            Priority: Minor
>         Attachments: HDFS-11270.001.patch, HDFS-11270.002.patch
>
>
> Currently there are missing three options introduction in {{HDFSCommands.md}} of command
{{hdfs namenode [-bootstrapStandby]}}. Now this command can support {{-force}}, {{-nonInteractive}}
and a additional option {{-skipSharedEditsCheck}}. It will be better to document what's the
meaning of these options and that will let users know how to use it correctly.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message