hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weiwei Yang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11189) WebHDFS and FollowRedirects
Date Wed, 07 Dec 2016 15:58:59 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11189?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15729093#comment-15729093
] 

Weiwei Yang commented on HDFS-11189:
------------------------------------

Hello [~guadilla]

{{HttpURLConnection}} class has a static method [setFollowRedirects|https://docs.oracle.com/javase/7/docs/api/java/net/HttpURLConnection.html#setFollowRedirects(boolean)]
sets a global flag, and [setInstanceFollowRedirects |https://docs.oracle.com/javase/7/docs/api/java/net/HttpURLConnection.html#setInstanceFollowRedirects(boolean)]
is using that as a default value. So it could be possible other libraries calls {{setFollowRedirects}}
that changes the behaviour. 

However I just tried to set this value to false and tested open() *2-step-opt* and getFileBlockLocations()
*1-step-opt*, 
{code}
HttpURLConnection.setFollowRedirects(false);
WebHdfsFileSystem sw = (WebHdfsFileSystem) FileSystem.get(new URI(uri), conf);
FSDataInputStream in = sw.open(new Path(path));
...
{code} 
they both worked fine. What was the error you saw? Can you get this issue reproduced?

> WebHDFS and FollowRedirects
> ---------------------------
>
>                 Key: HDFS-11189
>                 URL: https://issues.apache.org/jira/browse/HDFS-11189
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: webhdfs
>    Affects Versions: 2.7.3
>         Environment: We are using webhdfs from a j2ee environment with java 6. In the
web application we have a lot of libraries: spring, jersey, jackson...
>            Reporter: Oscar Guadilla
>         Attachments: WebHdfsFileSystem.java
>
>
> In some cases with simple operations (get file - non two step operation) we detect that
FollowRedirects flag of http comes as "false" and it makes webhdfs crash.
> We don't really know which library change this behavior and it is really strange because
the change is done directly in the jvm because in other wars/ears of the same j2ee server
it fails also. If we restart the j2ee server it starts working again.
> To fix the problem we changed the WebHdfsFileSystem class adding "setInstanceFollowRedirects(true)"
in the connection management instead of supposing that it should be true and it works fine.
> The same problem arises both in 1.x and 2.x webhdfs. We didn't test in 3.x
> Could you fix it? We did it in our environment but it would fine in it could be included
in the next releases.
> Thanks in advance,
> Oscar



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message