hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arpit Agarwal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11182) Update DataNode to use DatasetVolumeChecker
Date Mon, 19 Dec 2016 22:54:58 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15762551#comment-15762551

Arpit Agarwal commented on HDFS-11182:

Thanks for the feecback [~xyao]!

Pushed the following commit:

- Removed the semaphore as both you and [~manju_hadoop] commented on it, replaced with a simple
counter initialized to the number of volumes.
- Factored out some common code in tests you pointed out into a {{@Before}} method.

[~manju_hadoop], to address your other point about shared code between the sync and async
checks, there's a couple of differences that make it move it into a common method.

> Update DataNode to use DatasetVolumeChecker
> -------------------------------------------
>                 Key: HDFS-11182
>                 URL: https://issues.apache.org/jira/browse/HDFS-11182
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode
>            Reporter: Arpit Agarwal
>            Assignee: Arpit Agarwal
> Update DataNode to use the DatasetVolumeChecker class introduced in HDFS-11149 to parallelize
disk checks.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message