hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uma Maheswara Rao G (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10885) [SPS]: Mover tool should not be allowed to run when Storage Policy Satisfier is on
Date Thu, 01 Dec 2016 22:19:58 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10885?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15713254#comment-15713254

Uma Maheswara Rao G commented on HDFS-10885:

Overall patch looks nice to me. Great work [~zhouwei].

Except the corner cases of double checking, everything fine. Do you mind filing another JIRA
for checking that double check corner cases as we identified some cases before? I am ok with

I am ok to push this JIRA in, though I have small point to discuss.
Its regarding configuration item name.
 The API what we are exposing is named as isStoragePolicySatisfierActive. This two items would
be exposed to users, So, I feel we should unify in name to avoid confusions.
How about naming the parameter some thing like, (option 1) dfs.storage.policy.satisfier.activate
= true ? or to avoid Active/Standby HA confusions, (option 2) we need to change API name like

What do you think [~rakeshr] and others?
I feel #2 may be more appropriate considering dynamic enable disable options.
Other than this point, patch can be pushed.

> [SPS]: Mover tool should not be allowed to run when Storage Policy Satisfier is on
> ----------------------------------------------------------------------------------
>                 Key: HDFS-10885
>                 URL: https://issues.apache.org/jira/browse/HDFS-10885
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: HDFS-10285
>            Reporter: Wei Zhou
>            Assignee: Wei Zhou
>             Fix For: HDFS-10285
>         Attachments: HDFS-10800-HDFS-10885-00.patch, HDFS-10800-HDFS-10885-01.patch,
HDFS-10800-HDFS-10885-02.patch, HDFS-10885-HDFS-10285.03.patch, HDFS-10885-HDFS-10285.04.patch,
HDFS-10885-HDFS-10285.05.patch, HDFS-10885-HDFS-10285.06.patch, HDFS-10885-HDFS-10285.07.patch,
HDFS-10885-HDFS-10285.08.patch, HDFS-10885-HDFS-10285.09.patch
> These two can not work at the same time to avoid conflicts and fight with each other.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message