hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10759) Change fsimage bool isStriped from boolean to an enum
Date Tue, 27 Dec 2016 22:15:58 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10759?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15781388#comment-15781388
] 

Hadoop QA commented on HDFS-10759:
----------------------------------

| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} reexec {color} | {color:blue}  0m  0s{color} | {color:blue}
Docker mode activated. {color} |
| {color:red}-1{color} | {color:red} patch {color} | {color:red}  0m  6s{color} | {color:red}
HDFS-10759 does not apply to trunk. Rebase required? Wrong Branch? See https://wiki.apache.org/hadoop/HowToContribute
for help. {color} |
\\
\\
|| Subsystem || Report/Notes ||
| JIRA Issue | HDFS-10759 |
| JIRA Patch URL | https://issues.apache.org/jira/secure/attachment/12837786/HDFS-10759.0002.patch
|
| Console output | https://builds.apache.org/job/PreCommit-HDFS-Build/17959/console |
| Powered by | Apache Yetus 0.5.0-SNAPSHOT   http://yetus.apache.org |


This message was automatically generated.



> Change fsimage bool isStriped from boolean to an enum
> -----------------------------------------------------
>
>                 Key: HDFS-10759
>                 URL: https://issues.apache.org/jira/browse/HDFS-10759
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: hdfs
>    Affects Versions: 3.0.0-alpha1, 3.0.0-beta1, 3.0.0-alpha2
>            Reporter: Ewan Higgs
>              Labels: hdfs-ec-3.0-must-do
>         Attachments: HDFS-10759.0001.patch, HDFS-10759.0002.patch
>
>
> The new erasure coding project has updated the protocol for fsimage such that the {{INodeFile}}
has a boolean '{{isStriped}}'. I think this is better as an enum or integer since a boolean
precludes any future block types. 
> For example:
> {code}
> enum BlockType {
>   CONTIGUOUS = 0,
>   STRIPED = 1,
> }
> {code}
> We can also make this more robust to future changes where there are different block types
supported in a staged rollout.  Here, we would use {{UNKNOWN_BLOCK_TYPE}} as the first value
since this is the default value. See [here|http://androiddevblog.com/protocol-buffers-pitfall-adding-enum-values/]
for more discussion.
> {code}
> enum BlockType {
>   UNKNOWN_BLOCK_TYPE = 0,
>   CONTIGUOUS = 1,
>   STRIPED = 2,
> }
> {code}
> But I'm not convinced this is necessary since there are other enums that don't use this
approach.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message