hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kihwal Lee (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10997) Reduce number of path resolving methods
Date Mon, 24 Oct 2016 22:14:58 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10997?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15603385#comment-15603385

Kihwal Lee commented on HDFS-10997:

Sorry, took a while to review.  The change looks good and makes code more readable and consistent
in general. I hope this reduces chance of accidentally introducing inconsistencies or bugs
in path handling and checks.


> Reduce number of path resolving methods
> ---------------------------------------
>                 Key: HDFS-10997
>                 URL: https://issues.apache.org/jira/browse/HDFS-10997
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Daryn Sharp
>            Assignee: Daryn Sharp
>         Attachments: HDFS-10997.1.patch, HDFS-10997.2.patch, HDFS-10997.patch
> FSDirectory contains many methods for resolving paths to an IIP and/or inode.  These
should be unified into a couple methods that will consistently do the basics of resolving
reserved paths, blocking write ops from snapshot paths, verifying ancestors as directories,
and throwing if symlinks are encountered.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message