hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiaoyu Yao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10930) Refactor Datanode IO operations into a single class
Date Mon, 03 Oct 2016 23:13:20 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10930?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15543709#comment-15543709
] 

Xiaoyu Yao commented on HDFS-10930:
-----------------------------------

No, the goal is not to merge all these classes above into one mega-class. The proposal is
to wrap IO related datanode operations for easy instrumentation, metric collection, logging
and trouble shooting of datanode performance issues. 

> Refactor Datanode IO operations into a single class
> ---------------------------------------------------
>
>                 Key: HDFS-10930
>                 URL: https://issues.apache.org/jira/browse/HDFS-10930
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>            Reporter: Xiaoyu Yao
>            Assignee: Xiaoyu Yao
>
> Datanode IO (Disk/Network) related operations and instrumentations are currently spilled
in many classes such as DataNode.java, BlockReceiver.java, BlockSender.java, FsDatasetImpl.java,
FsVolumeImpl.java, DirectoryScanner.java, BlockScanner.java, FsDatasetAsyncDiskService.java,
LocalReplica.java, LocalReplicaPipeline.java, Storage.java, etc. This ticket is opened to
consolidate them into a single class. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message