hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Virajith Jalaparti (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10637) Modifications to remove the assumption that FsVolumes are backed by java.io.File.
Date Tue, 20 Sep 2016 00:06:20 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10637?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15505094#comment-15505094
] 

Virajith Jalaparti commented on HDFS-10637:
-------------------------------------------

Hi [~eddyxu], 

A couple of questions:

bq. In {{FsVolumeImpl}} can you remove {{this.currentDir}}?

Can you confirm which one are you referring to? In the constructor? If so, is the intent to
change the name of the argument passed into the constructor?

bq. {{FsDatasetSpi#getFileInFinalizedDir()}}, it still returns a File. Is there a way to eliminate
it?

It is used only in {{TestDirectoryScanner}}. One way to addressed this is to use {{FsVolumeImpl.getFinalizedDir}}
as before. This function is marked {{@VisibleForTesting}}, and is used in a couple of other
tests. Another way would be essentially rewrite parts of the {{TestDirectoryScanner}} which
use this function. In this case, some of the tests (e.g., {{TestScanInfo}}) do not make sense
as they rely on a File being created for a block, and then check if the file exists or not.
What do you think?

> Modifications to remove the assumption that FsVolumes are backed by java.io.File.
> ---------------------------------------------------------------------------------
>
>                 Key: HDFS-10637
>                 URL: https://issues.apache.org/jira/browse/HDFS-10637
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, fs
>            Reporter: Virajith Jalaparti
>            Assignee: Virajith Jalaparti
>         Attachments: HDFS-10637.001.patch, HDFS-10637.002.patch, HDFS-10637.003.patch,
HDFS-10637.004.patch, HDFS-10637.005.patch, HDFS-10637.006.patch, HDFS-10637.007.patch, HDFS-10637.008.patch
>
>
> Modifications to {{FsVolumeSpi}} and {{FsVolumeImpl}} to remove references to {{java.io.File}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message