hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manoj Govindassamy (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDFS-10553) DiskBalancer: Rename Tools/DiskBalancer class to Tools/DiskBalancerCLI
Date Thu, 08 Sep 2016 18:34:20 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10553?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15474649#comment-15474649
] 

Manoj Govindassamy edited comment on HDFS-10553 at 9/8/16 6:33 PM:
-------------------------------------------------------------------

org.apache.hadoop.hdfs.tools.DiskBalancer is more of a Tool/App than of a CLI Shell. Wondering
if the refactoring org.apache.hadoop.hdfs.tools.DiskBalancer to org.apache.hadoop.hdfs.tools.DiskBalancerTool
/ org.apache.hadoop.hdfs.tools.DiskBalancerCommand would be better compared to org.apache.hadoop.hdfs.tools.DiskBalancerCLI.
I am ok with either names. [~anu], your thoughts ? 


was (Author: manojg):
org.apache.hadoop.hdfs.tools.DiskBalancer is more of a Tool/App than of a CLI Shell. Wondering
if the refactoring org.apache.hadoop.hdfs.tools.DiskBalancer to org.apache.hadoop.hdfs.tools.DiskBalancerTool
would be better compared to org.apache.hadoop.hdfs.tools.DiskBalancerCLI. I am ok with either
names. [~anu], your thoughts ? 

> DiskBalancer: Rename Tools/DiskBalancer class to Tools/DiskBalancerCLI
> ----------------------------------------------------------------------
>
>                 Key: HDFS-10553
>                 URL: https://issues.apache.org/jira/browse/HDFS-10553
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: balancer & mover
>    Affects Versions: HDFS-1312
>            Reporter: Anu Engineer
>            Assignee: Manoj Govindassamy
>            Priority: Minor
>             Fix For: HDFS-1312
>
>
> Rename the Tools/DiskBalancer, since we have server/DiskBalancer class. This is confusing
when reading code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message