hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-10548) Remove the long deprecated BlockReaderRemote
Date Wed, 06 Jul 2016 01:39:11 GMT

     [ https://issues.apache.org/jira/browse/HDFS-10548?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Andrew Wang updated HDFS-10548:
    Hadoop Flags: Incompatible change,Reviewed  (was: Reviewed)
    Release Note: This removes the configuration property {{dfs.client.use.legacy.blockreader}},
since the legacy remote block reader class has been removed from the codebase.  (was: This
will obsoletes this configuration property, since the legacy block reader is removed from
the code base. {{dfs.client.use.legacy.blockreader}})

I also realized on second inspection that the LEGACY_BLOCKREADER config key is still present
in HdfsClientConfigKeys and DFSConfigKeys. How do we feel about removing it?

> Remove the long deprecated BlockReaderRemote
> --------------------------------------------
>                 Key: HDFS-10548
>                 URL: https://issues.apache.org/jira/browse/HDFS-10548
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: hdfs
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>             Fix For: 3.0.0-alpha1
>         Attachments: HDFS-10548-v1.patch, HDFS-10548-v2.patch, HDFS-10548-v3.patch
> To lessen the maintain burden like raised in HDFS-8901, suggest we remove {{BlockReaderRemote}}
class that's deprecated very long time ago. 
> From {{BlockReaderRemote}} header:
> {quote}
>  * @deprecated this is an old implementation that is being left around
>  * in case any issues spring up with the new {@link BlockReaderRemote2}
>  * implementation.
>  * It will be removed in the next release.
> {quote}
> From {{BlockReaderRemote2}} class header:
> {quote}
>  * This is a new implementation introduced in Hadoop 0.23 which
>  * is more efficient and simpler than the older BlockReader
>  * implementation. It should be renamed to BlockReaderRemote
>  * once we are confident in it.
> {quote}
> So even further, after getting rid of the old class, we could rename as the comment suggested:
BlockReaderRemote2 => BlockReaderRemote.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message