hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ewan Higgs (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDFS-9809) Abstract implementation-specific details from the datanode
Date Wed, 13 Jul 2016 14:33:21 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9809?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15375111#comment-15375111
] 

Ewan Higgs edited comment on HDFS-9809 at 7/13/16 2:33 PM:
-----------------------------------------------------------

Hi,
In Storage.java, I think a good deal of copyFileBuffered can be replaced with {{org.apache.commons.IOUtils.copy}}
(or {{copyLarge}}). {{fis}} could also be renamed {{fin}} to reflect the opposite of {{fout}}.

Across a lot of these files, loggers are using '\+' for string concatenation rather than using
sl4j templating (\{\}).   There is an ongoing effort (HADOOP-9864, HDFS-8971, etc) to get
these fixed up so instead of adding more LOG statements with '\+', try to take the opportunity
to clean it up as you go (though this just adds to this already rather large patch).


was (Author: ehiggs):
Hi,
In Storage.java, I think a good deal of copyFileBuffered can be replaced with {{org.apache.commons.IOUtils.copy}}
(or {{copyLarge}}). {fis}] could also be renamed {{fin}} to reflect the opposite of {{fout}}.

Across a lot of these files, loggers are using '\+' for string concatenation rather than using
sl4j templating (\{\}).   There is an ongoing effort (HADOOP-9864, HDFS-8971, etc) to get
these fixed up so instead of adding more LOG statements with '\+', try to take the opportunity
to clean it up as you go (though this just adds to this already rather large patch).

> Abstract implementation-specific details from the datanode
> ----------------------------------------------------------
>
>                 Key: HDFS-9809
>                 URL: https://issues.apache.org/jira/browse/HDFS-9809
>             Project: Hadoop HDFS
>          Issue Type: Task
>          Components: datanode, fs
>            Reporter: Virajith Jalaparti
>            Assignee: Virajith Jalaparti
>         Attachments: HDFS-9809.001.patch, HDFS-9809.002.patch, HDFS-9809.003.patch, HDFS-9809.004.patch
>
>
> Multiple parts of the Datanode (FsVolumeSpi, ReplicaInfo, FSVolumeImpl etc.) implicitly
assume that blocks are stored in java.io.File(s) and that volumes are divided into directories.
We propose to abstract these details, which would help in supporting other storages. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message