hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anu Engineer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10553) DiskBalancer: Rename Tools/DiskBalancer class to Tools/DiskBalancerCLI
Date Tue, 21 Jun 2016 19:21:57 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10553?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15342490#comment-15342490

Anu Engineer commented on HDFS-10553:

>From the mail that points out this issue from [~szetszwo]

- There are a few TODOs in the code.
- Tried the  help command "hdfs diskbalancer -help plan".  There is a typo "wetolerate" in
--thresholdPercentage.  Also, we should mention the unit for --bandwidth.
- We should avoid using the same class name such as DiskBalancer, which is defined in both
the datanode and tools packages.  It may be better to call it DiskBalancerCli for the one
in tools.
- I still think that it is better to use weighted mean and weighted variance in the calculation.

> DiskBalancer: Rename Tools/DiskBalancer class to Tools/DiskBalancerCLI
> ----------------------------------------------------------------------
>                 Key: HDFS-10553
>                 URL: https://issues.apache.org/jira/browse/HDFS-10553
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: balancer & mover
>    Affects Versions: HDFS-1312
>            Reporter: Anu Engineer
>            Assignee: Anu Engineer
>            Priority: Minor
>             Fix For: HDFS-1312
> Rename the Tools/DiskBalancer, since we have server/DiskBalancer class. This is confusing
when reading code.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message