hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10236) Erasure Coding: Rename replication-based names in BlockManager to more generic [part-3]
Date Thu, 26 May 2016 05:57:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10236?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15301581#comment-15301581
] 

Zhe Zhang commented on HDFS-10236:
----------------------------------

Thanks Rakesh for the work. Path LGTM overall. A few issues:
# I think {{addExpectedReplicasToPending}} means adding the actual expected replicas (instead
of *number of* expected replicas) to {{pendingReconstruction}}. So I don't think we should
change this name at this stage (as we discussed, *replica* is difficult to rename and we should
leave it until later).
# Similarly, the comment "// do not schedule more if enough redundancy is already pending"
doesn't read so well IMO. Maybe keeping it at this stage is better.
# {{int curExpectedReplicas = blockManager.getExpectedRedundancyNum(block);}} a little inconsistent.
Maybe rename the variable to {{curExpectedRedundancy}}?

+1 after appending.


> Erasure Coding: Rename replication-based names in BlockManager to more generic [part-3]
> ---------------------------------------------------------------------------------------
>
>                 Key: HDFS-10236
>                 URL: https://issues.apache.org/jira/browse/HDFS-10236
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>         Attachments: HDFS-10236-00.patch, HDFS-10236-01.patch
>
>
> The idea of this jira is to rename the following entity in BlockManager as,
> {{getExpectedReplicaNum}} to {{getExpectedRedundancyNum}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message