hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9869) Erasure Coding: Rename replication-based names in BlockManager to more generic [part-2]
Date Tue, 19 Apr 2016 08:19:25 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9869?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15247363#comment-15247363
] 

Rakesh R commented on HDFS-9869:
--------------------------------

Thanks [~zhz] for the review comments.
bq. Chain deprecation below. Maybe we should combine them?
How about keeping only the recent property name {{| dfs.namenode.replication.pending.timeout-sec
| dfs.namenode.reconstruction.pending.timeout-sec |}} and remove the old deprecated property
{{| dfs.replication.pending.timeout.sec | dfs.namenode.replication.pending.timeout-sec |}}
entry considering that this property {{dfs.replication.pending.timeout.sec}} was deprecated
long back and now we will be releasing {{3.0.0}} version?

bq. As a followup we should also deprecate other replication-related config keys.
Shall we do this deprecation through another follow-up jira task?

bq. Maybe we can also keep the "excess" in excessRedundancyMap? This matches better with the
getter.
I agree and will keep the term {{excess}} while preparing next patch.



> Erasure Coding: Rename replication-based names in BlockManager to more generic [part-2]
> ---------------------------------------------------------------------------------------
>
>                 Key: HDFS-9869
>                 URL: https://issues.apache.org/jira/browse/HDFS-9869
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>              Labels: hdfs-ec-3.0-must-do
>         Attachments: HDFS-9869-001.patch, HDFS-9869-002.patch, HDFS-9869-003.patch, HDFS-9869-004.patch
>
>
> The idea of this jira is to rename the following entities in BlockManager as,
> - {{PendingReplicationBlocks}} to {{PendingReconstructionBlocks}}
> - {{excessReplicateMap}} to {{extraRedundancyMap}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message