hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo Nicholas Sze (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9940) Rename dfs.balancer.max.concurrent.moves to avoid confusion
Date Wed, 16 Mar 2016 20:17:33 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15198077#comment-15198077

Tsz Wo Nicholas Sze commented on HDFS-9940:

Per the current implementation of public String reconfigurePropertyImpl(String property, String

DFS_DATANODE_BALANCE_MAX_NUM_CONCURRENT_MOVES_KEY is allowed to reconfigure without restarting

We need to check the code.  I beg it won't work since it requires DN restart in order to make
the new value effective.

> Rename dfs.balancer.max.concurrent.moves to avoid confusion
> -----------------------------------------------------------
>                 Key: HDFS-9940
>                 URL: https://issues.apache.org/jira/browse/HDFS-9940
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: balancer & mover
>    Affects Versions: 2.6.0
>            Reporter: John Zhuge
>            Assignee: John Zhuge
>            Priority: Minor
>              Labels: supportability
>             Fix For: 2.8.0
> It is very confusing for both Balancer and Datanode to use the same property {{dfs.datanode.balance.max.concurrent.moves}}.
It is especially so for the Balancer because the property has "datanode" in the name string.
Many customers forget to set the property for the Balancer.
> Change the Balancer to use a new property {{dfs.balancer.max.concurrent.moves}}.

This message was sent by Atlassian JIRA

View raw message