hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harsh J (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9940) Rename dfs.balancer.max.concurrent.moves to avoid confusion
Date Sun, 13 Mar 2016 12:56:33 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15192340#comment-15192340
] 

Harsh J commented on HDFS-9940:
-------------------------------

Agreed on the confusion when there's role-based config management involved - I'd also vote
for having Balancers discover the property from DNs directly/dynamically instead, which gives
the added benefit of allowing per-DN flexibility (should it get required in future) - HDFS-7466.

> Rename dfs.balancer.max.concurrent.moves to avoid confusion
> -----------------------------------------------------------
>
>                 Key: HDFS-9940
>                 URL: https://issues.apache.org/jira/browse/HDFS-9940
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: balancer & mover
>    Affects Versions: 2.6.0
>            Reporter: John Zhuge
>            Assignee: John Zhuge
>            Priority: Minor
>              Labels: supportability
>             Fix For: 2.8.0
>
>
> It is very confusing for both Balancer and Datanode to use the same property {{dfs.datanode.balance.max.concurrent.moves}}.
It is especially so for the Balancer because the property has "datanode" in the name string.
Many customers forget to set the property for the Balancer.
> Change the Balancer to use a new property {{dfs.balancer.max.concurrent.moves}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message