hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9857) Erasure Coding: Rename replication-based names in BlockManager to more generic [part-1]
Date Wed, 16 Mar 2016 04:51:33 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15196759#comment-15196759
] 

Rakesh R commented on HDFS-9857:
--------------------------------

Thanks [~zhz] for the reviews. I've attached patch addressing the comments.

Following are the changes done compare to the previous patch:
# Fixed 1st review comment.
# Modified variable {{underReplicatedBlocksCount}} to {{lowRedundancyBlocksCount}}
{code}
-  private volatile long underReplicatedBlocksCount = 0L;
+  private volatile long lowRedundancyBlocksCount = 0L;
{code}
# Modified {{neededReplications}} to {{neededReconstruction}}, {{under-replicated}} to {{low
redundancy}} in logs/comments
# Modified BlockManager method {{#processExtraRedundancyBlocksOnReCommission}} to {{#processExtraRedundancyBlocksOnReCommission}}
# Few changes done in TestReplicationPolicy.java - {{ChooseUnderReplicatedBlocks}} to {{ChooseLowRedundancyBlocks}}
and modified comments.

bq. fileReplication should be renamed. We can take care of it when we rename getExpectedReplicaNum
Since the current patch contains many changes, how about addressing couple of other items
including this through other sub-task?

> Erasure Coding: Rename replication-based names in BlockManager to more generic [part-1]
> ---------------------------------------------------------------------------------------
>
>                 Key: HDFS-9857
>                 URL: https://issues.apache.org/jira/browse/HDFS-9857
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>         Attachments: HDFS-9857-001.patch, HDFS-9857-02.patch
>
>
> The idea of this jira is to rename the following entities in BlockManager as,
> - {{UnderReplicatedBlocks}} to {{LowRedundancyBlocks}}
> - {{neededReplications}} to {{neededReconstruction}}
> - {{replicationQueuesInitializer}} to {{reconstructionQueuesInitializer}}
> Thanks [~zhz], [~andrew.wang] for the useful [discussions|https://issues.apache.org/jira/browse/HDFS-7955?focusedCommentId=15149406&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15149406]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message