hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDFS-9732) Remove DelegationTokenIdentifier.toString() —for better logging output
Date Sat, 26 Mar 2016 17:50:25 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9732?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15213127#comment-15213127
] 

Allen Wittenauer edited comment on HDFS-9732 at 3/26/16 5:49 PM:
-----------------------------------------------------------------

While I can appreciate what you folks are saying, experience has shown that Hadoop devs are
not disciplined enough to use this appropriately.  Incredibly bad code gets tossed over the
fence all the time that are obviously bad\-\-my current favorite for 2.8 is still the "log
metrics to files outside of the metrics subsystem via log4j rather than just fixing the file
metrics plug-in".  Something subtle like this difference is going to blow up big time. I still
believe that it should be harder to do the wrong thing, but I'll acquiesce in order to move
this forward.

That said, I'd still like to see:

a) audit *every* direct and indirect usage of toString to make sure it isn't getting used
for CLI output
b) the javadoc for the toString method needs to explicitly say that it is not to be used for
CLI output because it evolves and point to the relevant section in the compat guidelines
c) the toStringFrozen should be renamed toStringCLI or something similar to actually state
what it does not what it is so that in 3.x it can be changed.




was (Author: aw):
While I can appreciate what you folks are saying, experience has shown that Hadoop devs are
not disciplined enough to use this appropriately.  Incredibly bad code gets tossed over the
fence all the time that are obviously bad\-\-my current is still the "log metrics to files
outside of the metrics subsystem via log4j rather than just fixing the file metrics plug-in".
 Something subtle like this difference is going to blow up big time. I still believe that
it should be harder to do the wrong thing, but I'll acquiesce in order to move this forward.

That said, I'd still like to see:

a) audit *every* direct and indirect usage of toString to make sure it isn't getting used
for CLI output
b) the javadoc for the toString method needs to explicitly say that it is not to be used for
CLI output because it evolves and point to the relevant section in the compat guidelines
c) the toStringFrozen should be renamed toStringCLI or something similar to actually state
what it does not what it is so that in 3.x it can be changed.



> Remove DelegationTokenIdentifier.toString() —for better logging output
> ----------------------------------------------------------------------
>
>                 Key: HDFS-9732
>                 URL: https://issues.apache.org/jira/browse/HDFS-9732
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.7.2
>            Reporter: Steve Loughran
>            Assignee: Yongjun Zhang
>         Attachments: HADOOP-12752-001.patch, HDFS-9732.001.patch, HDFS-9732.002.patch
>
>   Original Estimate: 0.5h
>  Remaining Estimate: 0.5h
>
> HDFS {{DelegationTokenIdentifier.toString()}} adds some diagnostics info, owner, sequence
number. But its superclass,  {{AbstractDelegationTokenIdentifier}} contains a lot more information,
including token issue and expiry times.
> Because  {{DelegationTokenIdentifier.toString()}} doesn't include this data,
> information that is potentially useful for kerberos diagnostics is lost.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message