hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arpit Agarwal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-1477) Support reconfiguring dfs.heartbeat.interval and dfs.namenode.heartbeat.recheck-interval without NN restart
Date Fri, 04 Mar 2016 22:44:41 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1477?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15180677#comment-15180677
] 

Arpit Agarwal commented on HDFS-1477:
-------------------------------------

Hi [~xiaobingo], the patch looks almost ready. A few stylistic comments:
# Multiple calls to {{namesystem.getBlockManager.getDatanodeManager()}} in NameNode#reconfigurePropertyImpl.
Let's just make it a local variable to improve readability. e.g.
{code}
  protected String reconfigurePropertyImpl(String property, String newVal)
      throws ReconfigurationException {
    final DatanodeManager datanodeManager =
        namesystem.getBlockManager().getDatanodeManager();
{code}
# Similar change in testReconfigure for readability.
{code}
  public void testReconfigure() throws ReconfigurationException {
    // change properties
    final NameNode nameNode = cluster.getNameNode();
    final DatanodeManager datanodeManager = nameNode.namesystem
        .getBlockManager().getDatanodeManager();
{code}
# It is better to replace the sleep calls in {{TestDFSAdmin#testNameNodeGetReconfigurationStatus}}
with {{GenericTestUtils#waitFor}}.

Thanks for your patience with the patch revisions. 

> Support reconfiguring dfs.heartbeat.interval and dfs.namenode.heartbeat.recheck-interval
without NN restart
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: HDFS-1477
>                 URL: https://issues.apache.org/jira/browse/HDFS-1477
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>    Affects Versions: 2.7.0
>            Reporter: Patrick Kling
>            Assignee: Xiaobing Zhou
>         Attachments: HDFS-1477-HDFS-9000.006.patch, HDFS-1477-HDFS-9000.007.patch, HDFS-1477-HDFS-9000.008.patch,
HDFS-1477.005.patch, HDFS-1477.2.patch, HDFS-1477.3.patch, HDFS-1477.4.patch, HDFS-1477.patch
>
>
> Modify NameNode to implement the interface Reconfigurable proposed in HADOOP-7001. This
would allow us to change certain configuration properties without restarting the name node.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message