hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Masatake Iwasaki (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9726) Refactor IBR code to a new class
Date Tue, 02 Feb 2016 21:54:39 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9726?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15129110#comment-15129110

Masatake Iwasaki commented on HDFS-9726:

Thanks for working on this, [~szetszwo]. I think this is good improvement making datanode's
code clearer.

The patch looks good to me overall. Unit tests passed on my environment. Found some nits.

* {{IncrementalBlockReportManager#addRDBI}} should be VisibleForTesting and {{IncrementalBlockReportManager#sendImmediately}}
is not.
* {{notifyNamenodeBlock}}: I felt the meanings of {{send}} and {{now}} are not clear from
the variable name. How about {{immediate}} and {{notify}} respectively?

> Refactor IBR code to a new class
> --------------------------------
>                 Key: HDFS-9726
>                 URL: https://issues.apache.org/jira/browse/HDFS-9726
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>            Reporter: Tsz Wo Nicholas Sze
>            Assignee: Tsz Wo Nicholas Sze
>            Priority: Minor
>         Attachments: h9726_20160131.patch, h9726_20160201.patch
> The IBR code currently is mainly in BPServiceActor.  The JIRA is to refactor it to a
new class.

This message was sent by Atlassian JIRA

View raw message