hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7955) Improve naming of classes, methods, and variables related to block replication and recovery
Date Mon, 15 Feb 2016 05:50:18 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7955?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15146935#comment-15146935
] 

Rakesh R commented on HDFS-7955:
--------------------------------

Thanks [~umamaheswararao] for the reminder. Hi [~zhz], could you please point me to the task/jira
that will be used to fix the [2nd part|https://issues.apache.org/jira/browse/HDFS-7955?focusedCommentId=14389363&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14389363].
If not created yet then do you want to keep this umbrella jira open and create sub-tasks for
the same?

> Improve naming of classes, methods, and variables related to block replication and recovery
> -------------------------------------------------------------------------------------------
>
>                 Key: HDFS-7955
>                 URL: https://issues.apache.org/jira/browse/HDFS-7955
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: erasure-coding
>            Reporter: Zhe Zhang
>            Assignee: Rakesh R
>         Attachments: HDFS-7955-001.patch, HDFS-7955-002.patch, HDFS-7955-003.patch, HDFS-7955-004.patch,
HDFS-7955-5.patch
>
>
> Many existing names should be revised to avoid confusion when blocks can be both replicated
and erasure coded. This JIRA aims to solicit opinions on making those names more consistent
and intuitive.
> # In current HDFS _block recovery_ refers to the process of finalizing the last block
of a file, triggered by _lease recovery_. It is different from the intuitive meaning of _recovering
a lost block_. To avoid confusion, I can think of 2 options:
> #* Rename this process as _block finalization_ or _block completion_. I prefer this option
because this is literally not a recovery.
> #* If we want to keep existing terms unchanged we can name all EC recovery and re-replication
logics as _reconstruction_.  
> # As Kai [suggested | https://issues.apache.org/jira/browse/HDFS-7369?focusedCommentId=14361131&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14361131]
under HDFS-7369, several replication-based names should be made more generic:
> #* {{UnderReplicatedBlocks}} and {{neededReplications}}. E.g. we can use {{LowRedundancyBlocks}}/{{AtRiskBlocks}},
and {{neededRecovery}}/{{neededReconstruction}}.
> #* {{PendingReplicationBlocks}}
> #* {{ReplicationMonitor}}
> I'm sure the above list is incomplete; discussions and comments are very welcome.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message