hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo Nicholas Sze (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9654) Code refactoring for HDFS-8578
Date Wed, 27 Jan 2016 07:27:39 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9654?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15118792#comment-15118792

Tsz Wo Nicholas Sze commented on HDFS-9654:

> 2. Nit: Maybe make doUgrade method name a little more descriptive? How about hardLinkAndRename?:

I was going to rename the doUgrade method.  However, it does do more than hardLink and rename.
 It additionally does set cTime and writeProperties.  It won't looks good if we rename it
to hardLinkAndSetCTimeAndWritePropertiesAndRename.  We simply cannot encode everything in
the method name.

I also was going to fix the trailing whitespaces using git, although I always believe that
we should focus on the non-whitespace characters and ignore the whitespaces, especially the
trailing whitespaces.  Since there are no other changes, I won't post a new patch.  We could
commit the patch by "--whitespace=fix" command.

> Code refactoring for HDFS-8578
> ------------------------------
>                 Key: HDFS-9654
>                 URL: https://issues.apache.org/jira/browse/HDFS-9654
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>            Reporter: Tsz Wo Nicholas Sze
>            Assignee: Tsz Wo Nicholas Sze
>            Priority: Minor
>         Attachments: h9654_20160116.patch
> This is a code refactoring JIRA in order to change Datanode to process all storage/data
dirs in parallel; see also HDFS-8578.

This message was sent by Atlassian JIRA

View raw message