hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dinesh S. Atreya (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9607) Advance Hadoop Architecture (AHA) - HDFS
Date Mon, 04 Jan 2016 04:27:39 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9607?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15080683#comment-15080683

Dinesh S. Atreya commented on HDFS-9607:

Personal preference regarding API naming.

* We can prefer to use "writeInPlace" for the method name (as it is descriptive). Welcome
other suggestions.
* We can have auxiliary methods "updtInPlace" and "deleteInPlace" which will be no-ops performing
the check "checkWriteInPlace" or calling "writeInPlace". 

The Hadoop sub-systems such as ORC, HIVE, etc. may then override "updtInPlace" and "deleteInPlace"
methods to implement functionality relevant to each. 

> Advance Hadoop Architecture (AHA) - HDFS
> ----------------------------------------
>                 Key: HDFS-9607
>                 URL: https://issues.apache.org/jira/browse/HDFS-9607
>             Project: Hadoop HDFS
>          Issue Type: New Feature
>            Reporter: Dinesh S. Atreya
> Link to Umbrella JIRA
> https://issues.apache.org/jira/browse/HADOOP-12620 
> Provide capability to carry out in-place writes/updates. Only writes in-place are supported
where the existing length does not change.
> For example, "Hello World" can be replaced by "Hello HDFS!"
> See https://issues.apache.org/jira/browse/HADOOP-12620?focusedCommentId=15046300&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15046300
for more details.

This message was sent by Atlassian JIRA

View raw message