hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7955) Improve naming of classes, methods, and variables related to block replication and recovery
Date Thu, 28 Jan 2016 06:30:39 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7955?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15120875#comment-15120875
] 

Kai Zheng commented on HDFS-7955:
---------------------------------

Thanks for the discussions. I have two questions.
* Considering in most cases in names we have used word like {{striped}}, {{striping}}, {{ErasureCoding}},
{{EC}} and etc. to specify the context or avoid the confusion, do we still need to do the
rename for the names?
* OK, if we still do the rename, do we need to keep the word like {{striped}}? If we do, is
there any case other than striping in use of word {{reconstruction}} or like that?

Thanks.

> Improve naming of classes, methods, and variables related to block replication and recovery
> -------------------------------------------------------------------------------------------
>
>                 Key: HDFS-7955
>                 URL: https://issues.apache.org/jira/browse/HDFS-7955
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>            Reporter: Zhe Zhang
>            Assignee: Rakesh R
>         Attachments: HDFS-7955-001.patch, HDFS-7955-002.patch, HDFS-7955-003.patch
>
>
> Many existing names should be revised to avoid confusion when blocks can be both replicated
and erasure coded. This JIRA aims to solicit opinions on making those names more consistent
and intuitive.
> # In current HDFS _block recovery_ refers to the process of finalizing the last block
of a file, triggered by _lease recovery_. It is different from the intuitive meaning of _recovering
a lost block_. To avoid confusion, I can think of 2 options:
> #* Rename this process as _block finalization_ or _block completion_. I prefer this option
because this is literally not a recovery.
> #* If we want to keep existing terms unchanged we can name all EC recovery and re-replication
logics as _reconstruction_.  
> # As Kai [suggested | https://issues.apache.org/jira/browse/HDFS-7369?focusedCommentId=14361131&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14361131]
under HDFS-7369, several replication-based names should be made more generic:
> #* {{UnderReplicatedBlocks}} and {{neededReplications}}. E.g. we can use {{LowRedundancyBlocks}}/{{AtRiskBlocks}},
and {{neededRecovery}}/{{neededReconstruction}}.
> #* {{PendingReplicationBlocks}}
> #* {{ReplicationMonitor}}
> I'm sure the above list is incomplete; discussions and comments are very welcome.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message