hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Clampffer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9228) libhdfs++ should respect NN retry configuration settings
Date Mon, 30 Nov 2015 22:43:11 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9228?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15032635#comment-15032635

James Clampffer commented on HDFS-9228:

Looks good to me, just found 2 small things worth fixing.  I'm planning on committing HDFS-9144
before this, please let me know if it would be less painful to hold off on HDFS-9144 until
this gets in.

-RetryPolicy should probably have a virtual destructor, or maybe a comment saying members
can only be POD types.  I'd prefer the virtual destructor approach.
-In rpc_connection.cc line 37 "NO_RETRY" should be "kNoRetry" to keep consistent with the
naming conventions for constants.

> libhdfs++ should respect NN retry configuration settings
> --------------------------------------------------------
>                 Key: HDFS-9228
>                 URL: https://issues.apache.org/jira/browse/HDFS-9228
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: hdfs-client
>            Reporter: Bob Hansen
>            Assignee: Bob Hansen
>         Attachments: HDFS-9228.HDFS-8707.001.patch, HDFS-9228.HDFS-8707.002.patch, HDFS-9228.HDFS-8707.003.patch,
HDFS-9228.HDFS-8707.004.patch, HDFS-9228.HDFS-8707.005.patch, HDFS-9228.HDFS-8707.006.patch
> Handle the use case of temporary network or NN hiccups and have a configurable number
of retries for NN operations.

This message was sent by Atlassian JIRA

View raw message