hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8905) Refactor DFSInputStream#ReaderStrategy
Date Wed, 18 Nov 2015 00:35:11 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8905?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15009925#comment-15009925

Kai Zheng commented on HDFS-8905:

Thanks [~zhz] for the confirm. It looks pretty good to have the new names *readBlock* and
*readBuffer* as you suggested. They're much better than *doRead* that's more like an internal
method,  and also better than 4 *read* methods avoiding possible confusion between the two.
Will update the patch to address above comments.

> Refactor DFSInputStream#ReaderStrategy
> --------------------------------------
>                 Key: HDFS-8905
>                 URL: https://issues.apache.org/jira/browse/HDFS-8905
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>         Attachments: HDFS-8905-HDFS-7285-v1.patch, HDFS-8905-v2.patch
> DFSInputStream#ReaderStrategy family don't look very good. This refactors a little bit
to make them make more sense.

This message was sent by Atlassian JIRA

View raw message