hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8905) Refactor DFSInputStream#ReaderStrategy
Date Tue, 17 Nov 2015 21:45:11 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8905?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15009600#comment-15009600

Zhe Zhang commented on HDFS-8905:

I think extract {{ReaderStrategy}} as a standalone class with clear interfaces is a good idea.
The {{DFSInputStream}} class is on the big side and could use some simplifications. This also
avoid putting EC logic like {{copyFrom}} in the general input stream class.

Regarding naming: having 4 {{read}} methods doesn't look very clear. How about {{doRead}}
=> {{readBlock}} keeping {{copyFrom}} (or changing it to {{readBuffer}} so it looks more
aligned with {{readBlock}})?

We can do the branch-2 change separately.

> Refactor DFSInputStream#ReaderStrategy
> --------------------------------------
>                 Key: HDFS-8905
>                 URL: https://issues.apache.org/jira/browse/HDFS-8905
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>         Attachments: HDFS-8905-HDFS-7285-v1.patch, HDFS-8905-v2.patch
> DFSInputStream#ReaderStrategy family don't look very good. This refactors a little bit
to make them make more sense.

This message was sent by Atlassian JIRA

View raw message