hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7988) Replace usage of ExactSizeInputStream with LimitInputStream.
Date Tue, 24 Nov 2015 01:06:11 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7988?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15023522#comment-15023522
] 

Hudson commented on HDFS-7988:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk #2571 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/2571/])
HDFS-7988. Replace usage of ExactSizeInputStream with LimitInputStream. (wheat9: rev 298a8cb096906b5d688842f6520e90dc9779f0b3)
* hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocolPB/PBHelperClient.java
* hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/util/ExactSizeInputStream.java
* hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/util/TestExactSizeInputStream.java


> Replace usage of ExactSizeInputStream with LimitInputStream.
> ------------------------------------------------------------
>
>                 Key: HDFS-7988
>                 URL: https://issues.apache.org/jira/browse/HDFS-7988
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Chris Nauroth
>            Assignee: Walter Su
>            Priority: Minor
>              Labels: BB2015-05-TBR
>             Fix For: 2.8.0
>
>         Attachments: HDFS-7988.001.patch, HDFS-7988.002.patch
>
>
> HDFS has a class named {{ExactSizeInputStream}} used in the protobuf translation layer.
 This class wraps another {{InputStream}}, but constraints the readable bytes to a specified
length.  The functionality is nearly identical to {{LimitInputStream}} in Hadoop Common, with
some differences in semantics regarding premature EOF.  This issue proposes to eliminate {{ExactSizeInputStream}}
in favor of {{LimitInputStream}} to reduce the size of the codebase.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message