hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tony Wu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9282) Make data directory count and storage raw capacity related tests FsDataset-agnostic
Date Mon, 26 Oct 2015 16:11:28 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9282?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14974469#comment-14974469

Tony Wu commented on HDFS-9282:

Hi [~eddyxu],

Thank you very much for the detailed review. I have addressed all of your comments in the
new patch. Please take a look.

Regarding your comment:
* {{FsDatasetTestUtils#getNumOfDataDirs()}} should be renamed as {{getDefaultNumOfDataDirs()}}.
I was thinking the method in TestUtils may not always return the default value. Instead it
may choose to return some calculated value. But this is probably over-designing the API and
I have changed the name as you suggested.


> Make data directory count and storage raw capacity related tests FsDataset-agnostic
> -----------------------------------------------------------------------------------
>                 Key: HDFS-9282
>                 URL: https://issues.apache.org/jira/browse/HDFS-9282
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: HDFS, test
>    Affects Versions: 2.7.1
>            Reporter: Tony Wu
>            Assignee: Tony Wu
>            Priority: Minor
>         Attachments: HDFS-9282.001.patch
> DFSMiniCluster and several tests have hard coded assumption of the underlying storage
having 2 data directories (volumes). As HDFS-9188 pointed out, with new FsDataset implementations,
these hard coded assumption about number of data directories and raw capacities of storage
may change as well.
> We need to extend FsDatasetTestUtils to provide:
> * Number of data directories of underlying storage per DataNode
> * Raw storage capacity of underlying storage per DataNode.
> * Have MiniDFSCluster automatically pick up the correct values.

This message was sent by Atlassian JIRA

View raw message