hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mingliang Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9199) rename dfs.namenode.replication.min to dfs.replication.min
Date Mon, 05 Oct 2015 21:43:27 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14944104#comment-14944104

Mingliang Liu commented on HDFS-9199:

Thanks for reporting this. I agree that we need to make the replication config keys' name

I see
  public static final String  DFS_REPLICATION_MAX_KEY = "dfs.replication.max";
  public static final int     DFS_REPLICATION_MAX_DEFAULT = 512;

  public static final String  DFS_NAMENODE_REPLICATION_CONSIDERLOAD_KEY = "dfs.namenode.replication.considerLoad";
  public static final boolean DFS_NAMENODE_REPLICATION_CONSIDERLOAD_DEFAULT = true;
  public static final String  DFS_NAMENODE_REPLICATION_INTERVAL_KEY = "dfs.namenode.replication.interval";
  public static final int     DFS_NAMENODE_REPLICATION_INTERVAL_DEFAULT = 3;
  public static final String  DFS_NAMENODE_REPLICATION_MIN_KEY = "dfs.namenode.replication.min";
  public static final int     DFS_NAMENODE_REPLICATION_MIN_DEFAULT = 1;

Do we need to consider all of them as well? Which clause of renaming is preferred?

I think these keys are all used in namenode.

> rename dfs.namenode.replication.min to dfs.replication.min
> ----------------------------------------------------------
>                 Key: HDFS-9199
>                 URL: https://issues.apache.org/jira/browse/HDFS-9199
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Allen Wittenauer
>            Assignee: Mingliang Liu
> dfs.namenode.replication.min should be dfs.replication.min to match the other dfs.replication
config knobs.

This message was sent by Atlassian JIRA

View raw message