hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haohui Mai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-9170) Move libhdfs / fuse-dfs / libwebhdfs to hdfs-client
Date Fri, 09 Oct 2015 22:31:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-9170?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14951312#comment-14951312
] 

Haohui Mai commented on HDFS-9170:
----------------------------------

{noformat}
     [exec] CMake Error at CMakeLists.txt:19 (cmake_minimum_required):
     [exec]   CMake 2.8 or higher is required.  You are running version 2.6.4
{noformat}

It looks like it is complaining about cmake 2.8. Can you please manually change the CMakeLists.txt
to change the minimum required version to 2.6 to see whether it works?

> Move libhdfs / fuse-dfs / libwebhdfs to hdfs-client
> ---------------------------------------------------
>
>                 Key: HDFS-9170
>                 URL: https://issues.apache.org/jira/browse/HDFS-9170
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>             Fix For: 2.8.0
>
>         Attachments: HDFS-9170.000.patch, HDFS-9170.001.patch, HDFS-9170.002.patch, HDFS-9170.003.patch,
HDFS-9170.004.patch, native-package-build-fails-with-cmake-2.5.log
>
>
> After HDFS-6200 the Java implementation of hdfs-client has be moved to a separate hadoop-hdfs-client
module.
> libhdfs, fuse-dfs and libwebhdfs still reside in the hadoop-hdfs module. Ideally these
modules should reside in the hadoop-hdfs-client. However, to write unit tests for these components,
it is often necessary to run MiniDFSCluster which resides in the hadoop-hdfs module.
> This jira is to discuss how these native modules should layout after HDFS-6200.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message