hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8982) Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
Date Mon, 31 Aug 2015 21:38:46 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8982?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14724094#comment-14724094
] 

Jing Zhao commented on HDFS-8982:
---------------------------------

Actually I think here it's better to use {{getFileReplication}} instead of {{getPreferredBlockReplication}}.
This is because we're adding new blocks, which are not included in any historical snapshot.
For these blocks, the replication factor should be the file's current replication factor,
instead of the max replication factor.

But looks like the current code does not have consistent semantic. {{getFileReplication}}
and {{getPreferredBlockReplication}} are mixed in quota usage and block allocation. Maybe
we should use this change/jira to clean up this part.

> Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
> ----------------------------------------------------------------------------
>
>                 Key: HDFS-8982
>                 URL: https://issues.apache.org/jira/browse/HDFS-8982
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 2.7.1
>            Reporter: Zhe Zhang
>
> Currently {{INodeFile}} provides both {{getFileReplication}} and {{getPreferredBlockReplication}}
interfaces. At the very least they should be renamed (e.g. {{getCurrentFileReplication}} and
{{getMaxConfiguredFileReplication}}), with clearer Javadoc.
> I also suspect we are not using them correctly in all places right now.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message