hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (HDFS-8982) Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
Date Thu, 27 Aug 2015 23:47:46 GMT

     [ https://issues.apache.org/jira/browse/HDFS-8982?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Zhe Zhang reopened HDFS-8982:

bq. The so-called getPerferredBlockReplication() records the maximum replication factor of
the file w.r.t. the current and all snapshot state of the file.
[~wheat9] By using "so-called" I take that you agree we should at least give it a better name
(which was suggested in the JIRA description). Reopening the issue based on the consensus.

> Consolidate getFileReplication and getPreferredBlockReplication in INodeFile
> ----------------------------------------------------------------------------
>                 Key: HDFS-8982
>                 URL: https://issues.apache.org/jira/browse/HDFS-8982
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 2.7.1
>            Reporter: Zhe Zhang
> Currently {{INodeFile}} provides both {{getFileReplication}} and {{getPreferredBlockReplication}}
interfaces. At the very least they should be renamed (e.g. {{getCurrentFileReplication}} and
{{getMaxConfiguredFileReplication}}), with clearer Javadoc.
> I also suspect we are not using them correctly in all places right now.

This message was sent by Atlassian JIRA

View raw message