hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sreelakshmi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8956) Not able to start Datanode
Date Mon, 31 Aug 2015 04:37:45 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8956?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14722693#comment-14722693
] 

sreelakshmi commented on HDFS-8956:
-----------------------------------

@brahma Thank you for sharing the exact place to post the query and sorry for spamming jira
with unrelated issues. I am new to Hadoop and forums. I tried posting in hadoop user-mailing
list as you suggested. But in that I did not find any exact place to post my queries. Do I
have to send my issue to the provided e-mail ids. Please throw some light on this.

@Ajith S I am using the correct IP address, which was working earlier. I am able to do SSH
from namenode to datanode. And "Node Manager" is started on my faulty Data node PC. hosts
file I have cross checked and it seems to be fine, which I was using earlier and same file
is being used in other data nodes, which works fine. Please let me know, if I am missing anything
else.

@Rohan Rajeevan my dfs.datanode.http.address is configured as "0.0.0.0:50075" and dfs.datanode.address
is configured as "0.0.0.0:50010". Same configuration is used in other data nodes which are
working fine as well. And running netstat with below commands as root does not display anything,
as these ports are actually not in use.
 #netstat -plten | grep 50010
 #netstat -plten | grep 50075 

> Not able to start Datanode
> --------------------------
>
>                 Key: HDFS-8956
>                 URL: https://issues.apache.org/jira/browse/HDFS-8956
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: datanode, namenode
>    Affects Versions: 2.7.0
>         Environment: Centos
>            Reporter: sreelakshmi
>
> Data node service is not started on one of the data nodes, "java.net.bind exception"
is thrown. 
> Verified that ports 50010,50070 and 50075 are not in use by any other application.
> 15/08/26 01:50:15 INFO http.HttpServer2: HttpServer.start() threw a non Bind IOException
> java.net.BindException: Port in use: localhost:0
>         at org.apache.hadoop.http.HttpServer2.openListeners(HttpServer2.java:919)
>         at org.apache.hadoop.http.HttpServer2.start(HttpServer2.java:856)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.startInfoServer(DataNode.java:779)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.startDataNode(DataNode.java:1134)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.<init>(DataNode.java:434)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.makeInstance(DataNode.java:2404)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.instantiateDataNode(DataNode.java:2291)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.createDataNode(DataNode.java:2338)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.secureMain(DataNode.java:2515)
>         at org.apache.hadoop.hdfs.server.datanode.DataNode.main(DataNode.java:2539)
> Caused by: java.net.BindException: Cannot assign requested address



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message