hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8811) Move BlockStoragePolicy name's constants from HdfsServerConstants.java to HdfsConstants.java
Date Wed, 29 Jul 2015 14:20:07 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8811?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14646095#comment-14646095
] 

Hudson commented on HDFS-8811:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk #2198 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/2198/])
HDFS-8811. Move BlockStoragePolicy name's constants from HdfsServerConstants.java to HdfsConstants.java
(Contributed by Vinayakumar B) (vinayakumarb: rev 50887e5b07b6abb20c0edd74211e5612dc7b16da)
* hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/HdfsConstants.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/mover/TestStorageMover.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestBlockStoragePolicy.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/HdfsServerConstants.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockStoragePolicySuite.java
* hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt


> Move BlockStoragePolicy name's constants from HdfsServerConstants.java to HdfsConstants.java
> --------------------------------------------------------------------------------------------
>
>                 Key: HDFS-8811
>                 URL: https://issues.apache.org/jira/browse/HDFS-8811
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Vinayakumar B
>            Assignee: Vinayakumar B
>             Fix For: 2.8.0
>
>         Attachments: HDFS-8811-01.patch
>
>
> Currently {{HdfsServerConstants.java}} have following constants, 
> {code}  String HOT_STORAGE_POLICY_NAME = "HOT";
>   String WARM_STORAGE_POLICY_NAME = "WARM";
>   String COLD_STORAGE_POLICY_NAME = "COLD";{code}
> and {{HdfsConstants.java}} have the following
> {code}  public static final String MEMORY_STORAGE_POLICY_NAME = "LAZY_PERSIST";
>   public static final String ALLSSD_STORAGE_POLICY_NAME = "ALL_SSD";
>   public static final String ONESSD_STORAGE_POLICY_NAME = "ONE_SSD";{code}
> It would be better to move all these to one place HdfsConstants.java, which client APIs
also could access since this presents in hdfs-client module.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message