hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinayakumar B (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8811) Move BlockStoragePolicy name's constants from HdfsServerConstants.java to HdfsConstants.java
Date Mon, 27 Jul 2015 09:56:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8811?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14642517#comment-14642517
] 

Vinayakumar B commented on HDFS-8811:
-------------------------------------

Checkstyle and test failures are unrelated

> Move BlockStoragePolicy name's constants from HdfsServerConstants.java to HdfsConstants.java
> --------------------------------------------------------------------------------------------
>
>                 Key: HDFS-8811
>                 URL: https://issues.apache.org/jira/browse/HDFS-8811
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Vinayakumar B
>            Assignee: Vinayakumar B
>         Attachments: HDFS-8811-01.patch
>
>
> Currently {{HdfsServerConstants.java}} have following constants, 
> {code}  String HOT_STORAGE_POLICY_NAME = "HOT";
>   String WARM_STORAGE_POLICY_NAME = "WARM";
>   String COLD_STORAGE_POLICY_NAME = "COLD";{code}
> and {{HdfsConstants.java}} have the following
> {code}  public static final String MEMORY_STORAGE_POLICY_NAME = "LAZY_PERSIST";
>   public static final String ALLSSD_STORAGE_POLICY_NAME = "ALL_SSD";
>   public static final String ONESSD_STORAGE_POLICY_NAME = "ONE_SSD";{code}
> It would be better to move all these to one place HdfsConstants.java, which client APIs
also could access since this presents in hdfs-client module.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message