hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-8697) Refactor DecommissionManager: more generic method names and misc cleanup
Date Wed, 15 Jul 2015 21:25:04 GMT

     [ https://issues.apache.org/jira/browse/HDFS-8697?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Zhe Zhang updated HDFS-8697:
----------------------------
    Attachment: HDFS-8697.01.patch

Thanks Andrew for pointing out the issue.

Uploading new patch to revise {{replicated}} and {{stored}} related naming (generalizing them
with {{redundancy}}).

I filed HDFS-8786 as a follow-on to avoid reconstruction after decomm. The change could be
large because it breaks the implicit assumption that each internal block should have only
1 replica in common cases.

> Refactor DecommissionManager: more generic method names and misc cleanup
> ------------------------------------------------------------------------
>
>                 Key: HDFS-8697
>                 URL: https://issues.apache.org/jira/browse/HDFS-8697
>             Project: Hadoop HDFS
>          Issue Type: New Feature
>          Components: namenode
>    Affects Versions: 2.7.0
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8697.00.patch, HDFS-8697.01.patch
>
>
> This JIRA merges the changes in {{DecommissionManager}} from the HDFS-7285 branch, including
changing a few method names to be more generic ({{replicated}} -> {{stored}}), and some
cleanups.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message