hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ming Ma (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8688) replace shouldCheckForEnoughRacks with hasClusterEverBeenMultiRack
Date Thu, 16 Jul 2015 05:15:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8688?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14629210#comment-14629210
] 

Ming Ma commented on HDFS-8688:
-------------------------------

Thanks [~walter.k.su]! Overall it looks good.

{{ScriptBasedMapping#isSingleSwitch}} still checks if the script name is null. But it appears
that method is only used by test codes. Does that mean {{AbstractDNSToSwitchMapping#isSingleSwitch}}
isn't necessary anymore? Try to understand if all the "the script name == null implies single
rack" assumptions in the code can be removed.


> replace shouldCheckForEnoughRacks with hasClusterEverBeenMultiRack
> ------------------------------------------------------------------
>
>                 Key: HDFS-8688
>                 URL: https://issues.apache.org/jira/browse/HDFS-8688
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Walter Su
>            Assignee: Walter Su
>         Attachments: HDFS-8688.01.patch, HDFS-8688.02.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message