hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8495) Consolidate append() related implementation into a single class
Date Tue, 07 Jul 2015 06:41:04 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8495?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14616265#comment-14616265

Rakesh R commented on HDFS-8495:

Thanks [~wheat9] for the comments. I could see few of the {{*Op.java}} classes also have this
kind of usage, since it is minor changes I'm incorporating these changes in this jira. {{fsd.getBlockManager()}}
internally calling {{getFSNamesystem().getBlockManager()}}, I hope your comment on this is
to unify the calls by invoking it through {{fsd}} object, right?

Attached another patch with the following changes.
# Modified to {{fsd.isPermissionEnabled()}} in FsDirAppendOp.java and FsDirTruncateOp.java
# Modified the usage of {{fsn.getBlockManager()}} to {{fsd.getBlockManager()}} in FsDirAppendOp.java,
FSDirWriteFileOp.java, FSDirStatAndListingOp.java classes

> Consolidate append() related implementation into a single class
> ---------------------------------------------------------------
>                 Key: HDFS-8495
>                 URL: https://issues.apache.org/jira/browse/HDFS-8495
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>         Attachments: HDFS-8495-000.patch, HDFS-8495-001.patch, HDFS-8495-002.patch, HDFS-8495-003.patch,
HDFS-8495-003.patch, HDFS-8495-004.patch, HDFS-8495-005.patch, HDFS-8495-006.patch
> This jira proposes to consolidate {{FSNamesystem#append()}} related methods into a single

This message was sent by Atlassian JIRA

View raw message