hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8697) Refactor DecommissionManager: more generic method names and misc cleanup
Date Tue, 30 Jun 2015 01:13:04 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8697?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14606777#comment-14606777

Andrew Wang commented on HDFS-8697:

Hi Zhe, thanks for working on this, a couple review comments:

* "stored block" has a meaning elsewhere in the code base, we should use a different term.
Not sure what though. Sufficiently redundant? Sufficiently durable?
* Many log messages and comments still talk about replication.
* Explaining the expectations of decomming a DN with EC blocks somewhere would be good too.
Do we treat them like 1-repl blocks? Or allow a block to dip below full-strength redundancy?
It seems like the former (which I agree with), but should write this down somewhere.

> Refactor DecommissionManager: more generic method names and misc cleanup
> ------------------------------------------------------------------------
>                 Key: HDFS-8697
>                 URL: https://issues.apache.org/jira/browse/HDFS-8697
>             Project: Hadoop HDFS
>          Issue Type: New Feature
>          Components: namenode
>    Affects Versions: 2.7.0
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8697.00.patch
> This JIRA merges the changes in {{DecommissionManager}} from the HDFS-7285 branch, including
changing a few method names to be more generic ({{replicated}} -> {{stored}}), and some

This message was sent by Atlassian JIRA

View raw message