hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haohui Mai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8655) Refactor accesses to INodeFile#blocks
Date Wed, 24 Jun 2015 17:04:04 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8655?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14599745#comment-14599745

Haohui Mai commented on HDFS-8655:

bq. Rename setBlocks to setContiguousBlocks

Correct me if I'm wrong, I wonder why this is necessary as stripe blocks are inherited from

> Refactor accesses to INodeFile#blocks
> -------------------------------------
>                 Key: HDFS-8655
>                 URL: https://issues.apache.org/jira/browse/HDFS-8655
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 2.7.0
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8655.00.patch
> When enabling INodeFile support for striped blocks (mainly in HDFS-7749), HDFS-7285 branch
generalized the concept of blocks under an inode. Now {{INodeFile#blocks}} only contains contiguous
blocks of an inode. This JIRA separates out code refactors for this purpose. Two main changes:
> # Rename {{setBlocks}} to {{setContiguousBlocks}}
> # Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
> It also contains some code cleanups introduced in the branch.

This message was sent by Atlassian JIRA

View raw message