hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-8655) Refactor accesses to INodeFile#blocks
Date Fri, 26 Jun 2015 19:29:05 GMT

     [ https://issues.apache.org/jira/browse/HDFS-8655?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Zhe Zhang updated HDFS-8655:
    Attachment: HDFS-8655.01.patch

Updating patch to address comments from Haohui and Jing.

It also includes more consolidation so that {{blocks}} is only accessed by a getter and a
setter now. Moreover, {{setBlocks}}) is changed to private because the only external use can
be converted to a safer {{clearBlocks}} call.

> Refactor accesses to INodeFile#blocks
> -------------------------------------
>                 Key: HDFS-8655
>                 URL: https://issues.apache.org/jira/browse/HDFS-8655
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 2.7.0
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8655.00.patch, HDFS-8655.01.patch
> When enabling INodeFile support for striped blocks (mainly in HDFS-7749), HDFS-7285 branch
generalized the concept of blocks under an inode. Now {{INodeFile#blocks}} only contains contiguous
blocks of an inode. This JIRA separates out code refactors for this purpose. Two main changes:
> # Rename {{setBlocks}} to {{setContiguousBlocks}}
> # Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
> It also contains some code cleanups introduced in the branch.

This message was sent by Atlassian JIRA

View raw message