hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-8450) Erasure Coding: Consolidate erasure coding zone related implementation into a single class
Date Tue, 02 Jun 2015 06:01:18 GMT

     [ https://issues.apache.org/jira/browse/HDFS-8450?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kai Zheng updated HDFS-8450:
----------------------------
    Attachment: HDFS-8450-FYI.patch

Uploaded a pseudo "patch" illustrating some thoughts for your reference:
* It used {{FSDirErasureCodingOp}} name;
* FSDirErasureCodingOp accepts {{FSNamesystem fsn}} as parameter, instead of {{FSDirectory
fsd}};
* More functions renamed, to be consistent.

> Erasure Coding: Consolidate erasure coding zone related implementation into a single
class
> ------------------------------------------------------------------------------------------
>
>                 Key: HDFS-8450
>                 URL: https://issues.apache.org/jira/browse/HDFS-8450
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>         Attachments: HDFS-8450-FYI.patch, HDFS-8450-HDFS-7285-00.patch, HDFS-8450-HDFS-7285-01.patch,
HDFS-8450-HDFS-7285-02.patch, HDFS-8450-HDFS-7285-03.patch, HDFS-8450-HDFS-7285-04.patch,
HDFS-8450-HDFS-7285-05.patch
>
>
> The idea is to follow the same pattern suggested by HDFS-7416. It is good  to consolidate
all the erasure coding zone related implementations of {{FSNamesystem}}. Here, proposing {{FSDirErasureCodingZoneOp}}
class to have functions to perform related erasure coding zone operations.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message