hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8446) Separate safemode related operations in GetBlockLocations()
Date Thu, 18 Jun 2015 21:32:07 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8446?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14592553#comment-14592553
] 

Hudson commented on HDFS-8446:
------------------------------

FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #230 (See [https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/230/])
HDFS-8446. Separate safemode related operations in GetBlockLocations(). Contributed by Haohui
Mai. (wheat9: rev 015535dc0ad00c2ba357afb3d1e283e56ddda0d6)
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirStatAndListingOp.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirAttrOp.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
* hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java


> Separate safemode related operations in GetBlockLocations()
> -----------------------------------------------------------
>
>                 Key: HDFS-8446
>                 URL: https://issues.apache.org/jira/browse/HDFS-8446
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>            Priority: Minor
>             Fix For: 2.8.0
>
>         Attachments: HDFS-8446.000.patch, HDFS-8446.001.patch, HDFS-8446.002.patch, HDFS-8446.003.patch
>
>
> Currently {{FSNamesystem#GetBlockLocations()}} has some special cases when the NN is
in SafeMode. This jira proposes to refactor the code to improve readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message