hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-7317) Rename StoragePolicy
Date Tue, 30 Jun 2015 04:30:18 GMT

     [ https://issues.apache.org/jira/browse/HDFS-7317?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Vinod Kumar Vavilapalli updated HDFS-7317:
    Target Version/s: 2.8.0  (was: 2.6.0)

Moving features/enhancements out of previously closed releases into the next minor release

> Rename StoragePolicy
> --------------------
>                 Key: HDFS-7317
>                 URL: https://issues.apache.org/jira/browse/HDFS-7317
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.6.0
>            Reporter: Andrew Wang
> As discussed on HDFS-7285, StoragePolicy might not be the best name for what StoragePolicy
currently is, which is a hardcoded mapping to replica StorageTypes with a fallback, and being
able to specify a StorageType for creation vs. replication). Ideally the "policy" is what
determines the data temperature in the first place, with the temperature then mapping to the
actual StorageTypes to use.
> There were a number of suggestions presented, e.g. StorageTag, StoragePolicyTag. Let's
figure this out here.

This message was sent by Atlassian JIRA

View raw message