hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8450) Erasure Coding: Consolidate erasure coding zone related implementation into a single class
Date Sun, 31 May 2015 22:40:17 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8450?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14566803#comment-14566803

Kai Zheng commented on HDFS-8450:

Thanks Rakesh for the update. A few more comments:
1. Do we have to need the function now?
+  private static List<XAttr> createErasureCodingZone(final ECSchema schema,
+      final int cellSize, final String src, final FSDirectory fsd)
+      throws IOException {
+    fsd.writeLock();
+    try {
+      return fsd.ecZoneManager.createErasureCodingZone(src, schema, cellSize);
+    } finally {
+      fsd.writeUnlock();
+    }
+  }
2. Maybe getECSchema => getErasureCodingSchema as we did for others? Similar to getECSchemas.
+  static ECSchema getECSchema(final FSDirectory fsd, final INodesInPath iip)
3. Thanks for the following update. Maybe we could do further, getting rid of the {{pathIsInErasureCodingZone}}
parameter at all? I mean we could change the signature of functions like updateBlocks and
+      ECSchema ecSchema = FSDirErasureCodingZoneOp.getECSchema(fsDir, iip);
+      boolean pathIsInErasureCodingZone = ecSchema != null;
+      updateBlocks(fsDir, updateOp, iip, oldFile, ecSchema,
+          pathIsInErasureCodingZone);

> Erasure Coding: Consolidate erasure coding zone related implementation into a single
> ------------------------------------------------------------------------------------------
>                 Key: HDFS-8450
>                 URL: https://issues.apache.org/jira/browse/HDFS-8450
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>         Attachments: HDFS-8450-HDFS-7285-00.patch, HDFS-8450-HDFS-7285-01.patch, HDFS-8450-HDFS-7285-02.patch,
> The idea is to follow the same pattern suggested by HDFS-7416. It is good  to consolidate
all the erasure coding zone related implementations of {{FSNamesystem}}. Here, proposing {{FSDirErasureCodingZoneOp}}
class to have functions to perform related erasure coding zone operations.

This message was sent by Atlassian JIRA

View raw message