hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo Nicholas Sze (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8408) Revisit and refactor ErasureCodingInfo
Date Wed, 20 May 2015 12:06:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8408?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14552220#comment-14552220
] 

Tsz Wo Nicholas Sze commented on HDFS-8408:
-------------------------------------------

{quote}
There is EncryptionZone.java which provides details about EncryptionZone, returned with listEncryptionZones().

So IMO, keeping ErasureCodingZoneInfo would be helpful atleast for admin API. If we can include
zoneDir also in HdfsFileStatus, then this may be unnecessary.
{quote}
Thanks for clarifying it.  I agree that we should keep something like ErasureCodingZoneInfo.
 However, how about renaming it to ErasureCodingZone?  The ec zone related code should correspond
to encryption zone code.  Otherwise, it will be quite confusing.

> Revisit and refactor ErasureCodingInfo
> --------------------------------------
>
>                 Key: HDFS-8408
>                 URL: https://issues.apache.org/jira/browse/HDFS-8408
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Vinayakumar B
>            Assignee: Vinayakumar B
>
> As mentioned in HDFS-8375 [here|https://issues.apache.org/jira/browse/HDFS-8375?focusedCommentId=14544618&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14544618]

> {{ErasureCodingInfo}} needs a revisit.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message