hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haohui Mai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8394) Move getAdditionalBlock() and related functionalities into a separate class
Date Mon, 18 May 2015 18:13:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8394?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14548437#comment-14548437
] 

Haohui Mai commented on HDFS-8394:
----------------------------------

This refactoring is a part of the larger refactoring to break down {{FSNamesystem}} and {{FSDirectory}}
(which have 7842 and 1713 lines respectively today) into smaller but logically self-contained
pieces.

By breaking down things into small pieces we hope that we can control the visibility scopes
in finer grains and make the code easier to reason about. For example, refactoring the rename
related operations into {{FSDirRenameOp}} limits the visibility scope of the complicated {{RenameOperation}}
within {{FSDirRenameOp}} only. It is easier to understand and make changes of the rename operations.

Breaking down {{FSNamesystem}} and {{FSDirectory}} will also allow developments like HDFS-8286
which requires significant surgeries on these two classes to be kept in sync of trunk easier.

> Move getAdditionalBlock() and related functionalities into a separate class
> ---------------------------------------------------------------------------
>
>                 Key: HDFS-8394
>                 URL: https://issues.apache.org/jira/browse/HDFS-8394
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>             Fix For: 2.8.0
>
>         Attachments: HDFS-8394.000.patch, HDFS-8394.001.patch, HDFS-8394.002.patch, HDFS-8394.003.patch,
HDFS-8394.004.patch, HDFS-8394.005.patch, HDFS-8394.006.patch
>
>
> This jira proposes to move the implementation of getAdditionalBlock() and related functionalities
to a separate class to open up the possibilities of further refactoring and improvements.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message